small medium large xlarge

15 Dec 2013, 00:09
William Shea (2 posts)

When I approve the authorization, I’m redirect to the oauth2callback with /approval added an bunch of additional data. For this obviously get an error 500 because it is not part of the servlet. Is the behavior expect or did I miss something?


15 Dec 2013, 00:38
William Shea (2 posts)

I figured it out…


had to be added to the appengineweb.xml

26 Jan 2014, 04:15
Eric Redmond (21 posts)


Yes, this, along with the SessionUtils (and a few other GAE boilerplate code) are not covered in the book. Although I still feel that SessionUtils (or most of the Util files) have no home in the text, I think you make a fair point about this setting. I’ll add a comment to enable this in the next book revision.

Thanks for the suggestion,


01 Apr 2014, 11:58
Bill Girten (1 post)


I followed this chapter exactly as written. I’m also getting the 500 server error. Like William, I have enabled the sessions in appengineweb.xml. I still get the error.

So, I forked your project in GitHub, applied the client ID and secret and still get the 500 error. What else could give me this error?

Do I have access to any logs on GAE?

Last question: I noticed that when the project is deployed to GAE, the URL has a “1-dot” or “2-dot” prepended. Must I change the settings on the Developer’s Console as well?

05 Apr 2014, 03:29
Parva Thakkar (2 posts)

You get this error because of 1-dot or 2-dot added. So, to solve your issue and answer your second question follow this - After you deploy to GAE, you’ll see 1-dot or 2-dot. Don’t do anything there. Go back to app engine home page and open application from there. When you open application from there, you won’t see 1-dot or 2-dot there. Now, click on LunchRoulette and you should be fine.

You are getting 500 error because OAUTH2 didn’t know to go to 1-dot URL.

You must be logged in to comment