small medium large xlarge

Back to: All Forums  CoffeeScript
20 Feb 2015, 19:19
Daniel Hinz (1 post)

I have done the bower install of sinon, which does not load the lolex package. I tried doing a bower install of lolex but it reports package not found. I can do an npm install of lolex. However, I still get the following:

0/0 tests failed Warning: FATAL ERROR undefined: Failed to load module lolex from /lolex.js (parent: sinon/sinon/util/fake_timers) Error: Failed to load module lolex from /lolex.js (parent: sinon/sinon/util/fake_timers) at HTMLScriptElement.handler <__intern/node_modules/dojo/dojo.js:731:13> Use –force to continue.

Aborted due to warnings.

I have clearly gotten something wrong but don’t know where I should look. Any ideas are welcomed.

Running MacOS 10.10.2 Running Selenium standalone server with chromedriver sinon 1.12.2 (although I did try 1.12.0) lolex 1.2.1 intern 2.2.2


18 Mar 2015, 17:44
Trevor Burnham (53 posts)

It looks like this is an open bug in Sinon: Sadly, Sinon’s AMD support has always been clumsy, and installing it with Bower does not install its lolex dependency. That was an oversight on my part: I bumped the Sinon version from 1.11.1 to 1.12.1 to fix a different AMD bug, but ignored the addition of lolex as noted in the changelog:

I think the important thing here is this caveat in the Sinon README: It effectively says that Sinon just isn’t written to work with AMD when installed via Bower. So, I would try downloading the latest build from (That build includes lolex as part of the same JS file.) Please let me know if that helps!

You must be logged in to comment