small medium large xlarge

Generic-user-small
08 Apr 2015, 10:13
Louis Hansen (1 post)

Hi,

I’ve discovered a funny little inconsistency when using Cloc and Code_maat which causes the python merge script to behave a little erratically. Simply put, the issue is that if you are running on windows, then code_maat will format its paths with the unix style “/” and Cloc will by default format with the windows style “". This causes any filename that is in a subfolder to not be read correctly. The solution is very simple, just tack on the “–unix” when running Cloc on Windows and it will use the unix style “/”.

Generic-user-small
01 May 2015, 00:02
James (1 post)

You sir, are a steely-eyed missile man. Thank you for the fix.

Adamtornhill copy_pragsmall
01 May 2015, 10:19
Adam Tornhill (14 posts)

Yes, thanks a lot Louis for spotting this issue and for providing the workaround!

If we do a future edition of the book I’ll include a note to Windows users to specify the –unix flag when running cloc.

In the meantime, I’ve pushed a workaround to the Python scripts. You can get a new version at the Code Maat Download Site. But please note that I think generating the data on the “right” format (that is –unix) is a simpler and better solution.

You must be logged in to comment