small medium large xlarge

Generic-user-small
02 Oct 2014, 17:56
Robert C. Gann (4 posts)

I’m so glad you have created a new edition of the book. Thanks for all the work!

Am I doing something stupid? I’ve installed the CanaryMod server and accepted the EULA in two different environments: Windows 8.1 Pro with Java 7 (in Parallels) and the Mac OS X 10.10 with Java 8. I’ve tried CanaryMod-1.7.10-1.1.0 through 1.1.2 in almost all configurations, although I think the 1.1.2 version may require an additional jar file.

When I type either op or /op with my Minecraft username, I get the error [CanaryMod] [INFO] [NOTICE]: Failed to op with my Minecraft username. This error happens very quickly; I doubt it is contacting Minecraft to authenticate my username.

I know you must be exhausted, but I’d appreciate any suggestions. I’m stumped. Thanks!

Andy-talking_pragsmall
02 Oct 2014, 18:56
Andrew Hunt (227 posts)

First off, thanks! Now on to opping…

Sounds like a network error of some sort, as best as we can tell. We haven’t had this happen around here.

You could try adding your player name to server/config/ops.cfg, but I think it really needs the UUID in ops.xml. Could something have corrupted your databases in server/db? Try starting in a fresh, empty directory.

Also, you might try running in offline mode (see server.cfg).

Definitely stick with 1.1.2, there are some random bugs in earlier versions that will break a few of the plugins.

Let us know what you find…

/\ndy

Generic-user-small
03 Oct 2014, 13:57
Robert C. Gann (4 posts)

Thanks for your prompt response.

I’m currently using the first edition of your book as the textbook for a course I’m teaching. The students love it. I’m planning to use the second edition of your book as a text for a January term course, although I’m trying to get prepared for a quick switch to the second edition in case the Bukkit server stops working with Microsoft’s version of Minecraft or in case the Bukkit documentation disappears.

I think I actually have two issues.

First, in Windows 8.1 inside Parallels, I cannot get op to work. I always start with a fresh server directory. My current thought is that I have to run

playermod add username group

before running the op command. I’m not sure what group to use, although visitors and admin sound likely.

My second issue is in my native OS: Mac 10.10 with Java 8. There I cannot run the CanaryMod.jar file. I’m going to try setting my computer up to run two version of Java.

I have not tried the offline suggestion. I’ll try that after my class.

Thanks for any suggestions! I promise to tell my wife that I want more Pragmatic books for Christmas!

Me_pragsmall
05 Oct 2014, 01:01
Randy Eppinger (1 post)

Hi Andy and Robert. Same problem here. Andy, were you suggesting that manually adding to ops.cfg is the same as running the ops command?

Thanks.

Andy-talking_pragsmall
06 Oct 2014, 15:01
Andrew Hunt (227 posts)

As near as we can figure, this seems to be a bug in the server. It actually did op you correctly, but it’s incorrectly reporting that it failed.

Also, Robert you say “I cannot run the CanaryMod.jar file”, please provide us with some details.

So for now, just do the op command and trust that it really did work ;)

/\ndy

Generic-user-small
07 Oct 2014, 00:05
Robert C. Gann (4 posts)

I’m running Mac OS X 10.10, since I wanted to get a look at Swift. I get the same errors with Java 6, 7, and 8. I’ve probably done something stupid since I’ve had since try it and get it to work. Or, it could be one of the crazy things I’ve had happen with Yosemite.

Here is the beginning of a long list of errors.

Roberts-MBP-3:server2 gannr$ ./start_minecraft Please wait while the libraries initialize… Starting: CanaryMod 1.7.10-1.1.2 Canary Path: /Users/gannr/Desktop/server2/CanaryMod.jar & Working From: /Users/gannr/Desktop/server2 Registered xml Database Found 0 plugins; total: 0 [19:59:32] [CanaryMod] [INFO]: Starting: CanaryMod 1.7.10-1.1.2 [19:59:32] [CanaryMod] [INFO]: Canary Path: /Users/gannr/Desktop/server2/CanaryMod.jar & Working From: /Users/gannr/Desktop/server2 [19:59:32] [CanaryMod] [INFO]: Registered xml Database [19:59:32] [CanaryMod] [INFO]: Found 0 plugins; total: 0 [19:59:33] [net.minecraft.server.dedicated.DedicatedServer] [INFO]: Starting minecraft server version 1.7.10 [19:59:33] [net.minecraft.server.dedicated.DedicatedServer] [INFO]: Loading properties [19:59:33] [net.minecraft.server.dedicated.DedicatedServer] [INFO]: Generating keypair [19:59:33] [CanaryMod] [ERROR]: Error on line 1: Premature end of file. net.canarymod.database.exceptions.DatabaseWriteException: Error on line 1: Premature end of file. at net.canarymod.database.xml.XmlDatabase.updateSchema(XmlDatabase.java:244) ~[CanaryMod.jar:1.7.10-1.1.2] at net.canarymod.database.DataAccess.createTable(DataAccess.java:268) [CanaryMod.jar:1.7.10-1.1.2] at net.canarymod.database.DataAccess.(DataAccess.java:46) [CanaryMod.jar:1.7.10-1.1.2] at net.canarymod.backbone.GroupDataAccess.(GroupDataAccess.java:15) [CanaryMod.jar:1.7.10-1.1.2] at net.canarymod.backbone.BackboneGroups.(BackboneGroups.java:26) [CanaryMod.jar:1.7.10-1.1.2] at net.canarymod.user.UserAndGroupsProvider.(UserAndGroupsProvider.java:32) [CanaryMod.jar:1.7.10-1.1.2] at net.canarymod.CanaryMod.initUserAndGroupsManager(CanaryMod.java:77) [C

Thanks!

Andy-talking_pragsmall
07 Oct 2014, 00:31
Andrew Hunt (227 posts)

Ah, that’s different. Try removing all the files in server/db/*, and try again. Let me know if that works.

/\ndy

Generic-user-small
07 Oct 2014, 04:07
Andrew Enfield (2 posts)

I’m using the 2nd edition of the book, with Java 8 on OS X, and Canary 1.1.2 for Minecraft 1.7.10. I’m seeing what I think is the same message:

** [21:01:45] [CanaryMod] [INFO] [NOTICE]: Failed to op **

I think you said that it is actually adding the user? Should this mean that it actually changes the config/ops.cfg file so that it includes this user? I stopped the server, checked the file, and it doesn’t contain the user I specified, FWIW.

Can’t check more… have to put kids to bed. :-).

Andy-talking_pragsmall
07 Oct 2014, 14:44
Andrew Hunt (227 posts)

Not ops.cfg, but db/operators.xml.

Also, the Canary guys may have fixed this by now. Try the very latest development snapshot release.

/\ndy

Generic-user-small
09 Oct 2014, 02:18
Andrew Enfield (2 posts)

Ah - got it. It does appear that my account is part of the operators list, I think from the original attempt that displayed the above message. I downloaded and used the latest development snapshot, and when I tried to add my account, it told me I was already an operator.

Thanks!

2014-m_pragsmall
05 May 2015, 07:29
Junichi Ito (1 post)

I got “Failed to op” error too, but resolved by switching to nightly build: https://ci.visualillusionsent.net/job/CanaryMod/805/

  • java version “1.8.0_25”
  • Mac OS X 10.10.3
Generic-user-small
19 Jul 2015, 00:17
James Kang (1 post)

I am a new user and I am unable to op myself. Received a “Could not execute command… java.lang.NullPointerException”

Using java version 1.7.0_79, CanaryMod-1.8.0, Ubuntu 14.10

Can anyone advise?

2014-06-05-114630_pragsmall
26 Jul 2015, 15:59
Nic Ferrier (2 posts)

Yeah, I get the same thing.

CanaryMod-1.8.0-1.2.0-RC1.jar on Ubuntu with Oracle java 1.8

Not sure what the username would be anyway… my mojang username?

2014-06-05-114630_pragsmall
26 Jul 2015, 21:11
Nic Ferrier (2 posts)

Hmmm.

I fixed mine by using the config/ops.cfg and adding the email address that is registered with mojang. That seems to be correct because when I put a random username in the file CanaryMod complains on startup.

So I hope I’ve sorted that out.

Generic-user-small
08 Aug 2015, 15:56
Mike Thirlwell (1 post)

Also having this problem with CanaryMod 1.7.10-1.1.3

Can someone post a sample config/ops.cfg and db/operators.xml so I can try and fill them in manually and see if that works?

Here’s the error:

op IceR*****

[16:55:22] [CanaryMod] [WARN]: Failed to translate Username into a UUID > [16:55:22] [CanaryMod] [ERROR]: Could not execute command…

java.lang.NullPointerException

Cheers for any help you can provide!

Mike

Msb_pragsmall
24 Aug 2015, 11:23
Marcus Birkenkrahe (1 post)

@mike I just had the same problem and Nic Ferrier’s solution worked for me with different CanaryMod releases: enter your Mojang email in the op.cfg file and do erase the /db files (all .xml).

Also but I don’t know if that makes a difference, I am logged in at Mojang at the same time.

Generic-user-small
09 Sep 2015, 12:15
Mike Moses (1 post)

I have this problem and none of the solutions presented so far seem to work

I am using the CanaryMod-1.8.0-1.2.0-RC1.jar.

I found a post that suggested using the UUID with the op command. I also found a site mcuuid.net that said it could find the UUID from the player name. I gave me a UUID that I successfully used with the op command. I do not know how to verify that it is the correct UUID. Suggestions?

Is anyone else aware of that site? Any concerns?

Generic-user-small
14 Oct 2015, 13:46
Gerald Stappen (1 post)

Hello,

i tried everthing which was mentioned here before but i get always these error:

[15:41:41] [CanaryMod] [WARN]: Failed to translate Username into a UUID

When i start Minecraft with the server, it ist not possible to hit anything with the left mouse tab. In the normal version this is no problem, everything is ok. So there must be a problem with the server rights.

Can anyone help ?

Thanks. Gerald

Generic-user-small
27 Feb 2016, 04:33
Andrew Gray (1 post)

Hi Gerald and Mike,

I am running CanaryMod 1.8.0-1.2.0-RC1 under Mac OS X 10.10.5 with Java 1.8.0_73. When I entered the command “op Minecraft user name” I got an error starting with the following three lines

[10:00:11] [CanaryMod] [WARN]: Failed to translate Username into a UUID [10:00:11] [CanaryMod] [ERROR]: Could not execute command… java.lang.NullPointerException

followed by a Java stack trace.

As Mike suggested, I found that specifying a UUID seemed to work. When I enter “op UUID” I get:

[10:06:00] [CanaryMod] [INFO]: [SERVER] Opped

To find the UUID I used some advice form the comments at http://conoroneill.net/creating-a-valid-ops-file-in-json-format-for-minecraft-179/. Doing “cat /Users/username/Library/Application\ Support/minecraft/usercache.json”showed a JSON file with the UUID. Hope that helps.

Generic-user-small
29 Aug 2016, 01:07
Gil Wright (5 posts)

I suspect part of the problem will occur if you have never run the minecraft client before. Setup on a new box, followed all the instructions (including not to run the app yet) and that means there is no Application_Support/minecraft folder yet….

Ran the client. Looked in ~/Library/Application\ Support/minecraft/*.json, found the UUID entry which is a really long string like: “uuid”: “xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxxx”. Went to console and did “op xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxxx”. That worked.

Generic-user-small
14 Aug 2017, 04:54
Robbie Sidell (1 post)

Future travelers: I had the same problem (using CanaryMod 1.8.0 with [old] Minecraft 1.8.0) and couldn’t OP myself (per A. Hunt’s instruction).

Fix: added my username to the following file: “player.xml” in Desktop/Server/db. Look for the with your . In that entry, change the from "visitors" to "admins".

This updates “operators.xml” in the same folder.

You must be logged in to comment