small medium large xlarge

10 Sep 2016, 13:09
Guanghui Qu (2 posts)

I have followed the cider docs to add cider/cider-nrepl “0.14.0-SNAPSHOT” to my project.clj file .

But it still sucks. (Note: this way I could start the db connection, but the auto completion feature is missing)

I could use cider-jack-in to successfully setup the repl env but I can’t do db connection this way.

Here is my ~/.lein/profiles.clj

{:repl {:plugins [[cider/cider-nrepl “0.14.0-SNAPSHOT”] [refactor-nrepl “2.3.0-SNAPSHOT”]] :dependencies [[alembic “0.3.2”] [org.clojure/tools.nrepl “0.2.12”]]}}

Any suggestions will be welcome, thanks.

10 Sep 2016, 03:52
Guanghui Qu (2 posts)

I have found a workaround here:

21 Sep 2016, 00:00
R. Potter (1 post)

when you create your project simply add +cider to the option flags

lein new luminus swagger-service +swagger +cljs +cider
20 Dec 2016, 00:04
Matt DeBoard (1 post)

God bless you, R. Potter, whoever you are.

Note that in order to use this flag you have to ignore the book’s admonition to use the luminus template version and just use latest (as of this writing).

You must be logged in to comment