small medium large xlarge

Generic-user-small
12 Aug 2016, 03:52
Ricardo Rodriguez (7 posts)

I followed instructions on PDF where it says to execute:

sudo gem install rails –version=5.0.0.rc2 –no-ri –no-rdoc

but still when I do “rails –version” I get: Rails 4.2.5

Book it is not clear about how to change from the default install (Rails 4.2.5) to the one we installed with command given here.

Samr_small_pragsmall
12 Aug 2016, 10:44
Sam Ruby (634 posts)

Did you do the rm -rf * per the instructions? If not, you still have a Gemfile around that points to the old version of Rails. This command can be done after the gem install rails.

Generic-user-small
12 Aug 2016, 12:47
Ricardo Rodriguez (7 posts)

Oh,,, you are totally right, this worked. My bad, I guess it was too late at night when I was going over instructions lol.

Now, since I’m going over the electronic version of it I would have expect commands like rm -rf to be highlighted kind of like is done at $ sudo gem install rails --version=5.0.0.rc2 --no-ri --no-rdoc

Maybe that’s a good feedback or idea to enhance electronic version ?

Book is great and support is awesome, thank you so much.

You must be logged in to comment