small medium large xlarge

Generic-user-small
01 Feb 2009, 21:33
Peter Dalmaris (4 posts)

Hello,

I am trying to enable SSL for my rails app. I have installed the ssl_requirements plugin and added “include SslRequirement” in the application controller, as the recipe suggests. Then I restart the server and access the home page.

Then I am getting this error:

NameError in ProjectsController#index uninitialized constant SslRequirement::UserSystem

I have searched for this error, no luck. I notice that the plugin is correctly installed in the vendors directory. As soon as I remove the line “include SslRequirement”, my site works again.

What am I doing wrong??

Thanks again!

Generic-user-small
04 Feb 2009, 20:02
Ivan Oblomov (1 post)

You’re using an outdated version of the plugin. When installing plugins, always use GitHub as they typically have the most up-to-date versions.

http://github.com/rails/ssl_requirement/tree/master

Generic-user-small
06 Feb 2009, 10:17
Peter Dalmaris (4 posts)

Thanks Ivan, I’ll install the latest from Github and tested, no error message this time.

For others with the same problem, I used this command to install the plugin from Github: ` ./script/plugin install git://github.com/rails/ssl_requirement.git `

You must be logged in to comment