small medium large xlarge

Generic-user-small
12 Dec 2016, 04:30
Adewole Mayowa (6 posts)

All the Rspec tests didn’t work because of this. Phanjomjs is not working with angular 2.3.0 Comments online and on your twitter feed shows that you are well aware of this. Please update if you already have a solution. Thank you. I love your book and I am willing to read it as many times as possible until I grasp every bit of it. The name of the book should be “Full Stack Web Development for the Impatient”.

Dmfcb_pragsmall
12 Dec 2016, 15:16
David Copeland (476 posts)

Yeah, I discovered this this weekend. The next update to the beta will use yarn and include a lockfile to ensure you are on Angular 2.1 (install instructions are: https://yarnpkg.com/en/docs/install )

In the meantime, you can edit your package.json to only pull in the 2.1 versions of the Angular dependencies and that should fix it.

If you are keen to try yarn in advance of the beta, here is the package.json and yarn.lock as of the end of the testing chapter:

https://gist.github.com/davetron5000/eff83b72e87b2061fd674cfa645e9c1e

Save those files (view Raw, then save) to the root of your rails app, then yarn install and you should be good to go.

You must be logged in to comment