small medium large xlarge

28555da_pragsmall
05 Jan 2018, 14:20
David Wilbur (50 posts)

rails new shine  --skip-turbolinks --skip-spring  --skip-test --webpack=angular -d postgresql

the most success I had with getting angular to work was when I used the above syntax verses using:


bin/rails webpacker:install:angular

however once I got to pdf p1_0 page 74 I had the same issue others had with a blank page. is there a way to tell it to use a specific version at creation/install time vs editing out what seems to be the current default of:


  "dependencies": {
    "@angular/common": "^5.1.3",
    "@angular/compiler": "^5.1.3",
    "@angular/core": "^5.1.3",
    "@angular/forms": "^5.1.3",
    "@angular/http": "^5.1.3",
    "@angular/platform-browser": "^5.1.3",
    "@angular/platform-browser-dynamic": "^5.1.3",

and instead start with something like (copied from dcbang-code.tgz 6/20 package.json):

"dependencies": {
    "@angular/common": "^4.1.3",
    "@angular/compiler": "^4.1.3",
    "@angular/core": "^4.1.3",
    "@angular/forms": "^4.1.3",
    "@angular/http": "^4.1.3",
    "@angular/platform-browser": "^4.1.3",
    "@angular/platform-browser-dynamic": "^4.1.3",

note from https://v4.angular.io/docs it appears 4.4.6 is current for v4, and 5.1.3 for v5.

You must be logged in to comment