small medium large xlarge

28555da_pragsmall
12 Oct 2017, 16:36
David Wilbur (49 posts)

yarn seems to be going through a recurring issue with what are described in these:

https://github.com/yarnpkg/yarn/issues/4433 https://github.com/yarnpkg/yarn/issues/4342

since I had installed yarn (v1.0.1 some point in august I think…) prior to getting to this part of the book I still had an outdated yarn when I got to doing the material related to Webpacker and React (around page 200) thus, It might be worth while also encouraging the reader to update yarn (and maybe node) at the same time that they install Webpacker and React.

note, at this time I still see dependency issues, but they seem to be erroneous.

warning "postcss-cssnext@3.0.2" has unmet peer dependency "caniuse-lite@^1.0.30000697".
warning "webpack-dev-server@2.9.1" has unmet peer dependency "webpack@^2.2.0 || ^3.0.0".
warning "webpack-dev-middleware@1.12.0" has unmet peer dependency "webpack@^1.0.0 || ^2.0.0 || ^3.0.0".

there is also a ticket about this.

You must be logged in to comment