small medium large xlarge

04 Aug 2010, 23:52
Leonid Raiz (7 posts)

I downloaded and installed InstantRails 2.0 according to instructions on pages 32-34. The installation appeared to be all right. However whenever I try to run “gem update” I get a message

ERROR: While executing gem … (Gem::RemoteSourceException) HTTP Response 301 fetching

Apparently yaml file was moved. I guessing its probable url is now but I can’t figure out what/how to change in the existing 2.0 installation to be able to update it to 2.2 or 2.3.

By the way, attempts to run “gem install rubygems-update” lead to the same error message.

Any suggestions?

05 Aug 2010, 17:32
Emanuel Timebend (1 post)

I had the same problem. The URL was in one of the several defaults.rb files. I changed it to the new URL and tried updating again. I wasn’t getting the 301 error anymore, but instead:

C:\instantrails>gem update –system Updating RubyGems… ERROR: While executing gem … (Gem::RemoteSourceException) HTTP Response 302 fetching

C:\instantrails>gem update rails Updating installed gems… ERROR: While executing gem … (Gem::RemoteSourceException) HTTP Response 302 fetching

…a 302 response! Cool!

05 Aug 2010, 17:56
Leonid Raiz (7 posts)

I also posted this question in rubygems forum - You may want to watch this url as well.

13 Aug 2010, 20:58
Leonid Raiz (7 posts)

I ended up going through following steps 1. Download zip from 2. Unzip into a temporary directory that I made under InstantRails 2.0 installation 3. From running Instant Rails application opened Ruby Console windows and cd to the unzip directory 4. Manually installed with: ruby setup.rb 5. Added new remote source with: gem sources –add

You must be logged in to comment