small medium large xlarge

12 Aug 2008, 01:28
gb (8 posts)
I tried to download the jemmy.jar from the jemmy site . It doesn’t seem to be working correctly .
When I download from any browser (safari,firefox,omniweb) on the mac.
I goto the license page. (
Click accept
the URL changes to this
nothing happens.
I dragged this to the download manager in safari and I end up with a file
I removed the .txt and put it in the junquenote folder with the jruby_basics.rb
(which I moved to the junquenote folder.)
I try to launch
I get this error message
cannot load Java class org.netbeans.jemmy.JemmyProperties (NameError)

When I try to load the jemmy.jar with jar launcher it say’s the file is corrupt . I tried building it from the sources with ant but the folder I downloaded is missing a build.xml file ?

I can get junquenote to launch after much work trying to get the jruby thing worked out. Just can’t get jruby_basics to run.

any insight as to what I’m doing wrong would be helpful thanks g

12 Aug 2008, 19:55
Ian Dees (207 posts)

Hi, gb.

I can replicate the error; looks like a broken link on the Web server. The NetBeans project appears to have recently switched to hgweb/hgwebdir to serve their source code, and I’m guessing that build products like @jemmy.jar@ aren’t getting checked into source control. I’ll contact them to ask for an updated download link.

In the meantime, “here”: is a recent (and to my knowledge unaltered) version from May of this year, offered under the terms of the GPL. This link comes with the standard disclaimers about trusting URLs you find in forum posts, and will go away as soon as the one on is working again.

The file can go into your @CLASSPATH@ or one of the paths in JRuby’s @$:@ variable. Here’s one possibility for OS X. Assuming @jemmy.jar@ is saved in the early_success directory, alongside @jruby_basics.rb@:

ln -s ../junquenote/junquenote_app.rb
CLASSPATH=. jruby jruby_basics.rb
12 Dec 2008, 03:27
Massimiliano Giroldi (4 posts)

Fri Dec 12 01:16:04 -0200 2008

The same broken link :)

12 Dec 2008, 18:53
Ian Dees (207 posts)

Hello, Massimiliano.

Yes, the link at is still broken, and the bug tickets for them to update the link are still open.

But my old copy is still available at That should be enough to get you up and running.


15 Dec 2008, 19:22
Ian Dees (207 posts)

The Jemmy project has moved, and they now have a working link to the jar on their new “download”: page. I’ve done a little quick testing of this version with the scripts from the book, and signs are encouraging.

07 Oct 2010, 14:33
Gianni Pucciani (3 posts)

Hi, in that download page I don’t see a jemmy.jar, which one should I use? I tried JemmyCore but there is no JemmyProperties module in there. Is there an errata for the code at page 24? Thanks.

07 Oct 2010, 15:13
Gianni Pucciani (3 posts)

I downloaded jemmy- from, and managed to run the example. HTH for others.

You must be logged in to comment