small medium large xlarge

05 May 2009, 12:22
Stephen Gallo (1 post)

When I create a link for my publisher the one line template appears on facebook however the entire line is a hyperlink. I would expect only the “Click to View Food” would be a link. This example has a hard coded url, but i’ve also tried a route such as bark_url(:id => and still no luck. The whole line is linked.

I’ve watched to 2nd FBer video and downloaded the source and cannot figure out for the life of me why it is doing this. I’m using the version of facebooker from the github repo as of 5/4/2009.

The template appears to have registered correctly with facebook. This is what the FB developer tool has.

Primary One Line Template
{*actor*} just ate {*meal_type*} - {*meal_type_link*}

Cheers, Stephen Gallo

  def meal_template
    one_line_story_template "{*actor*} just ate {*meal_type*} - " +  "{*meal_type_link*}"
    short_story_template "{*actor*} just ate {*meal_type_link*}", render(:partial => "short_meal")
  #call UserPublisher.deliver_meal(user)
  def meal(meal)
    send_as :user_action
    from meal.user.facebook_session.user #must call session
    data :meal_post =>, 
         :meal_type => meal.meal_type,
         :meal_type_link => link_to("Click to View the Food"," +
05 May 2009, 20:49
Mike Mangino (543 posts)

Wow, that’s a really odd problem. I’m guessing the HTML in the call to link_to is a forum software issue. What happens if you don’t include any link at all? can you look at what the data hash looks like by running @UserPublisher.create_meal(meal).data@

You must be logged in to comment