small medium large xlarge

Back to: All Forums  Core Data
04 Jul 2010, 22:02
Norm Hecht (4 posts)

This is an issue with the version directly from the downloaded code: I haven’t changed anything, with the exception of changing the Active SDK from 10.5 to 10.6, and that didn’t change a thing as far as I could tell.

I wanted to add a new ingredient to a recipe, and was able to create a new ingredient using the Edit Ingredients pane. I then clicked the button to add a new recipeItem to the recipe, which created a new row in the table. Clicking the combo box in the name column brought up a list of the ingredients I had created, so I selected one, but it didn’t take: the cell remained blank. I had the same issue with the Unit of Measure column.

Saving also failed, with the “Multiple validation errors” method, although if I undid the creation of the new recipeIngredient, I could.

This is the

05 Jul 2010, 23:14
Marcus S. Zarra (284 posts)

What project version are you having an issue with?

Have you downloaded the code recently?

17 Jul 2010, 18:04
Norm Hecht (4 posts)

Sorry for the delay–I got distracted with other projects.

It’s the third version of the app, downloaded on July 4.


23 Jul 2010, 18:27
Marcus S. Zarra (284 posts)

Thank you, I will take a look at the sample code and see what is going on.

20 Feb 2011, 16:05
Brent Kendall (1 post)

hey, is there any news on this. I just bought the ebook and was working through everything. I downloaded your example code and went to version 3 of the Recipes example. I can’t save recipe ingredients or there mesurements.

Is it possible to post a screenshot of which items we need to change to fix this.

11 Dec 2011, 20:30
Marcus S. Zarra (284 posts)

The sample code should be working. Please let me know if you are still having an issue.

01 Jan 2013, 18:17
Yasushi Noguchi (1 post)

I recently bought the book and tried to test the samples. Then, same thing happened on “GrokkingRecipes_v3”. Sample code that I god was on the following link.

I compiled “GrokkingRecipes_v3” and seemed to work. However, I could not save recipe ingredients.

Neither 10.8 nor 10.7 SDK worked.

I need any help to fix this problem.

03 Jan 2013, 00:56
Marcus S. Zarra (284 posts)

Your link is to he first edition code which has not been updated for the latest releases of OS X.

Can you ost the output you are seeing in the console?

Can you also describe the steps you are taking?

You must be logged in to comment