small medium large xlarge

Back to: All Forums  The RSpec Book
24 Feb 2011, 12:49
Crypto (1 post)

Here’s what you get if run “cucumber features” with Ruby 1.8.7 and Cucumber 0.9.2:

WARNING: no such file to load – 1.8/gherkin_lexer_en Couldn’t load 1.8/gherkin_lexer_en The $LOAD_PATH was: C:/Ruby187/lib/ruby/gems/1.8/gems/cucumber-0.9.2/bin/../lib …

There is no mention of this in the book at all even though the authors must have encountered it since I’m using the same versions they are. One site on the web indicates upgrading to Cucumber 0.9.4 solves this. It doesn’t. Yet another says this problem goes away if you upgrade to Ruby 1.9.x. Here’s the result:

WARNING: no such file to load – 1.9/gherkin_lexer_en Couldn’t load 1.9/gherkin_lexer_en The $LOAD_PATH was: C:/Ruby192/lib/ruby/gems/1.9.1/gems/cucumber-0.10.0/bin/../lib …

So that doesn’t work either.

Also, if you run “cucumber features” with an updated Ruby, you get this:

*** WARNING: You must use ANSICON 1.31 or higher ( to get coloured output on Windows

Which seems silly because the older Ruby (1.8.7) and older Cucumber (0.9.2 and 0.9.4) seem to give color just fine solely with the win32console gem. So upgrading means I get less functionality unless I use some other non-related tool.

This is not a fault of the book but it brings up my gripe session: some of this is exactly why newcomers that you try to show these concepts to get frustrated. Everything with Ruby feels clunky like this. Every time you turn around there’s some new incompatibility or warning or error or yet some other gem you have to load up. (This rarely happens with Python – but Python doesn’t have all the cool tools.) This all makes getting organizations into Ruby testing tools is somewhat difficult because there is a perception that supporting tools like Cucumber are barely holding themselves together and, again, it’s usually for reasons like I’m showing here.

I’ve been using this book to get people interested in concepts like Cucumber and except for the fact that Ruby always seems like it’s held together with spit and baling wire, it’s working. The book is well written. I just wish the supporting tools the book describes were more consistent in their implementation.

18 Jun 2012, 04:24
Mohammad Ashik Elahi (1 post)

Hi, I am anew comer and I have the same problem and frustrated towards Ruby. It should just work. But it doesn’t.

Regards Ashik

21 Jun 2012, 14:07
Gary Ferguson (1 post)

Ruby was initially built to run on open systems. It is getting better working with windows.

It runs perfectly on Linux.

I switched to Linux, and realized what has been missing in my life, a real good operating system and a great community.

Goodbye windows you took too many years of my life away from me.

03 Jul 2012, 19:54
Ken Green (1 post)

I am having the same LOAD_PATH problem. Although I am a novice, I am not new to Ruby, Rails, RSpec, or Cucumber. I am having the same load PATH problem that a lot of other people are having. I am running on RHEL and not Windows. I have found work-arounds for this problem that work when I run Cucumber or RSpec but not both at the same time. I have read the forums where Dave insists the code in the book works (for him). I even downloaded the samples and had the same issues. I am really getting put off by this. I need to learn this stuff but can’t say I’d recommend the book because of the LOAD_PATH problems.

The problem is that the code is in the lib directory. Code should be tested in it’s own project and not the lib directory of another project; which is the way this appears.

12 Jun 2013, 06:35
senthil kumar (1 post)

I am getting same error in windows 7. How to rectify this issue.